it-swarm-eu.dev

La ricerca intelligente restituisce 500 errori interni

Non riesco a capire come far funzionare Smart Search. Credo di averlo abilitato in modo appropriato e di avere un piccolo set di campioni indicizzato. Ma ogni volta che scrivo una ricerca ottengo un errore 500 interno. I registri di Apache mostrano:

"OTTIENI/componente/Finder/ricerca? Q = not & Itemid = 4816 HTTP/1.1" 500 31 " https://www.mysite.com/knowledge-base " "Mozilla/5.0 (Windows NT 10.0 ; Win64; x64) AppleWebKit/537.36 (KHTML, come Gecko) Chrome/60.0.3112.113 Safari/537.36 "porta: 443

Ho provato a controllare le autorizzazioni per le cartelle e qualsiasi altra cosa che potrebbe bloccare questa ricerca (come Strumenti di amministrazione). Senza fortuna. Qualche idea su come posso eseguire ulteriormente il debug?

1
Tom

Abilita la segnalazione degli errori sul sito (modificalo da "Nessuno" a "Massimo" nelle impostazioni di configurazione di Joomla), quindi controlla la pagina, dovresti vedere l'errore reale.

In genere, questi errori irreversibili sono causati da un plug-in non core poiché la ricerca intelligente principale non restituisce errori.

1
itoctopus

Dopo aver provato ad abilitare ogni singola impostazione di debug, non ha mai mostrato i dettagli del problema. Solo un "errore di sintassi".

Comunque è finito per essere qualcosa di semplice. Avevo bisogno di una voce di menu.

quick start docs sembra suggerire che potresti impostare un'interfaccia del modulo o un'interfaccia del componente. Ho fatto solo l'interfaccia del modulo.

Deve essere qualcosa nel mio ambiente, difficile credere che un errore di sintassi venga mostrato qui.

1
Tom