it-swarm-eu.dev

Errore durante l'aggiornamento da Joomla 2.5 a 3.3

Alla fine ho preso il mio ultimo aggiornamento per avere tutte le mie installazioni di joomla sulla loro versione attuale. così su quest'ultimo durante l'installazione del pacchetto di aggiornamento. ora sto ricevendo una pagina bianca e con la segnalazione degli errori attivata, questo errore dall'amministratore:

Strict Standards: Only variables should be assigned by reference in /home/tendesig/public_html/manabigama.com/plugins/system/jqueryintegrator/jqueryintegrator.php on line 38

Fatal error: Call to undefined method RuntimeException::get() in /home/tendesig/public_html/manabigama.com/libraries/joomla/error/error.php on line 797

e questo dal frontend:

Strict Standards: Only variables should be assigned by reference in /home/tendesig/public_html/manabigama.com/plugins/system/jqueryintegrator/jqueryintegrator.php on line 38

Strict Standards: Non-static method JApplicationSite::getMenu() should not be called statically, assuming $this from incompatible context in /home/tendesig/public_html/manabigama.com/plugins/system/jcemediabox/jcemediabox.php on line 251

Strict Standards: Non-static method JApplicationCms::getMenu() should not be called statically, assuming $this from incompatible context in /home/tendesig/public_html/manabigama.com/libraries/cms/application/site.php on line 279

Notice: Use of undefined constant DS - assumed 'DS' in /home/tendesig/public_html/manabigama.com/modules/mod_showplus/mod_showplus.php on line 45

Warning: require_once(/home/tendesig/public_html/manabigama.com/modules/mod_showplusDShelper.php): failed to open stream: No such file or directory in /home/tendesig/public_html/manabigama.com/modules/mod_showplus/mod_showplus.php on line 45

Fatal error: require_once(): Failed opening required '/home/tendesig/public_html/manabigama.com/modules/mod_showplusDShelper.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tendesig/public_html/manabigama.com/modules/mod_showplus/mod_showplus.php on line 45
3
TEN Design

In base ai rapporti sugli errori, i seguenti plug-in/moduli stanno causando problemi:

  1. jQuery Integrator (Plugin)

    • Secondo sito web degli sviluppatori , il plug-in non è più supportato. Inoltre, non è consigliabile attivare il plug-in per l'area di amministrazione:

      Attenzione: non attivare jQuery su backend (parametro 'attiva anche su backend' nella scheda avanzata) a meno che non si sia completamente sicuri di ciò che si sta facendo. jQuery non è assolutamente necessario in adminpanel e quelle estensioni che lo utilizzano portano automaticamente con sé jQuery. tushev.org

      Ci sono altre alternative disponibili qui, ma per Joomla 3.x, potresti non aver nemmeno bisogno di un plugin per usare jQuery, dato che ora è libreria javascript predefinita in Joomla. La maggior parte delle estensioni lo caricherà se necessario, e puoi anche caricare jQuery aggiungendo <?php JHtml::_('jquery.framework'); ?> al tuo modello o file di estensione.

  2. JCE Media Box (plugin)

    • Il plugin probabilmente non è aggiornato. Scarica l'ultima versione dal link sopra e installala.
  3. showplus (modulo)

    • Questo modulo di presentazione riporta diversi errori. Il download e l'installazione dell'ultima versione compatibile con Joomla 3 probabilmente risolverà i tuoi problemi.

(Per nascondere gli errori degli standard rigorosi, puoi andare su Configurazione globale → scheda Server → Segnalazione errori e impostarlo su None. Questo probabilmente non eliminerà l'errore irreversibile, tuttavia risolve davvero qualsiasi cosa.)

2
johanpw