it-swarm-eu.dev

Modulo menu non visualizzato / funzionante con ACL

Ho un menu utente ovvero X ed è assegnato a un modulo.

Ho anche creato un gruppo di utenti e un livello di accesso degli utenti. Quindi ho assegnato il livello di accesso dell'utente al gruppo di utenti che ho creato, ovvero Y. Tuttavia, quando assegno il livello di accesso dell'utente sul modulo, il modulo non viene visualizzato per me (su un account che ho creato e vi ha assegnato il gruppo di utenti).

Dove ho sbagliato? Grazie!

2
alinisme

Se non hai fatto confusione con qualcosa di più profondo e supponendo che si tratti di un'installazione casuale di joomla con le tue aggiunte ACL, allora è sicuramente qualcosa che non hai fatto bene o che hai ignorato nel creare il tuo gruppo utenti e il tuo livello di accesso.

Può essere una combinazione di se il tuo gruppo di utenti è o non è figlio di un altro gruppo di utenti e che mentre un gruppo di utenti registrato ha accesso al tuo Livello di accesso personalizzato, il tuo gruppo di utenti personalizzato no. Aggiungi nel mix che le voci di menu del tuo menu potrebbero avere anche impostazioni ACL e, a seconda del layout del Modulo, il modulo non verrà visualizzato affatto, se non c'è accesso al suo contenuto.

Fai un passo indietro dal sito Web e leggi un po 'la documentazione sull'implementazione di ACL in Joomla, al fine di ottenere una migliore comprensione.

Vorrei suggerire di iniziare lentamente la tua sperimentazione con l'ACL di Joomla, facendo piccoli cambiamenti e testando ciò che funziona e perché, poiché può essere davvero confuso e facilmente un sito Web può diventare disordinato.

2
FFrewin