it-swarm-eu.dev

Problème d'installation d'Openfire - Impossible de se connecter au panneau d'administration

J'essaie d'obtenir Openfire à installer sur une machine virtuelle Ubuntu, mais une fois le programme d'installation sur le Web terminé, je ne parviens pas à me connecter au panneau d'administration.

Jusqu'à présent, je:

  • programme d'installation Debian téléchargé
  • Installé à l'aide d'options d'achat d'actions
  • Base de données ajoutée et construction de la structure à l'aide du fichier SQL fourni
  • Installateur Web terminé

J'essaie maintenant de me connecter en utilisant le nom d'utilisateur: admin et mon mot de passe, mais je reçois constamment une erreur de nom d'utilisateur/mot de passe incorrect. Il existe un enregistrement généré dans la base de données MySQL montrant l'utilisateur administrateur avec un mot de passe crypté, et le passage à un mot de passe non codé ne fonctionne pas. Quel est le problème ici?

15
Lobe

J'ai eu le même problème, peu connu et il semble que ce soit un bug non documenté. Essayez de redémarrer le serveur après avoir effectué l'installation.

A travaillé pour moi.

23
SpaceManSpiff

J'ai dû définir manuellement le mot de passe, la page de configuration ne l'a pas enregistré. Le redémarrage du serveur n'a pas aidé.

Si vous utilisez la base de données intégrée sous Windows, ce sera dans embedded-db/openfire.script:

INSERT INTO OFUSER VALUES('admin',NULL, ...

Remplacez NULL par votre mot de passe. Redémarrez ensuite votre serveur OpenFire.

6
StuffMaster

Connexion administrateur Openfire Comment modifier la connexion administrateur Openfire lors de l'utilisation de Windows Vista et d'une base de données intégrée:

  1. Arrêtez Openfire
  2. En tant qu'administrateur Windows, éditez

    C:\Program Files (x86)\Openfire\embedded-db\openfire.script

  3. Changer la ligne qui ressemble à ceci

    INSÉRER DANS LES VALEURS DE L'UTILISATEUR ('admin', NULL, '', 'Administrator', 'admin', '0', '0')

    à

    INSÉRER DANS LES VALEURS DE L'UTILISATEUR ('admin', '', NULL, 'Administrator', 'admin', '0', '0')

  4. Enregistrez le fichier, quittez l'éditeur

  5. Redémarrez Openfire
3
hasan vidin

Nous installons et déployons OpenFire sur Ubuntu assez régulièrement. Voici une coupe/pâte rapide PARTIELLE de notre société interne Wiki. Nous pré-installons également webmin et/ou virtualmin sur certains serveurs juste pour faciliter les choses plus tard:

Pré-installation

Sudo -s

apt-get update && apt-get dist-upgrade

mkdir/home/kpwadmin/openfire-install

mkdir/home/kpwadmin/virtualmin-install

cd/home/kpwadimn/virtualmin-install

apt-get install Sun-Java6-jre

Installation

Téléchargez le dernier package .deb sur openfire.org. Nous utiliserons la version 3.6.2 d'Openfire dans cet article.

cd/home/oacadmin/openfire-install

wget http://www.igniterealtime.org/downloadServlet?filename=openfire/openfire_3.6.2_all.deb

Installez openfire_3.6.2_all.deb à l'aide de dpkg

dpkg -i openfire_3.6.2_all.deb

Créer une base de données MySQL pour Openfire

Lancez Firefox et accédez à serverip/phpmyadmin (exemple: 72.11.123.59/phpmyadmin), connectez-vous à phpmyadmin en tant que root.

privilèges de clic

ajouter un nouvel utilisateur

Nom d'utilisateur: openfire

Hôte: local

Mot de passe: "quelque chose de sécurisé"

Dans la section intitulée "Base de données pour l'utilisateur", cliquez sur le bouton radio "créer une base de données avec le même nom et accorder tous les privilèges"

cliquez sur 'aller'

Interface Web

Ouvrez un autre onglet sur firefox et accédez à serverip: 9090 (exemple: 123.0.0.59:9090) pour continuer l'installation à l'aide de l'interface Web.

sélectionner l'anglais

Etc, etc., etc.

J'espère que cela t'aides...

2
KPWINC

http://blog.taragana.com/index.php/archive/how-to-recover-openfire-admin-password/

mais ce n'est pas lié à la programmation ....

2
mog

Le redémarrage ne l'a pas fait pour moi, suivant les conseils ci-dessus, j'ai également modifié manuellement le fichier openfire.script (j'utilisais une base de données intégrée), puis j'ai pu me connecter très bien (Ubuntu 9.10)

0
Tronman

Eu le même problème avec une installation sur Windows en utilisant l'option de base de données intégrée. Désinstaller, effacer le répertoire, réinstaller ne l'a pas corrigé. Seul un redémarrage pourrait le guérir

0
Hightechrider

Consultez ce didacticiel complet pour installer Openfire et résoudre les problèmes courants.

http://www.expertcore.org/viewtopic.php?f=74&t=1851

0
NeoCambell

Par défaut, il est "admin" pour l'utilisateur et "admin" pour le mot de passe même si vous en fournissez un avec des fenêtres intégrées (Just fyi).

0
user181224

J'ai installé le paquet openfire.deb sur le serveur Ubuntu et j'ai eu le même problème: je n'ai même pas pu me connecter pour la première fois en tant qu'administrateur. J'ai fait ce qui suit: chmod o + rx/usr/share/openfire

Il s'est avéré que les utilisateurs n'avaient même pas l'autorisation de lire le répertoire. Je ne sais pas si c'est la bonne chose à faire, mais maintenant je peux me connecter :)

0
Dmitriy

En utilisant Openfire 3.7.1 sous Windows, le mot de passe de l'utilisateur admin était admin également - peu importe ce que je saisi lors de l'assistant de configuration.

Merci à cette réponse j'ai trouvé la ligne

INSERT INTO OFUSER VALUES('admin','admin',NULL,'Administrator','[email protected]','0','0')

dans le fichier embedded-db/openfire.script , il était donc facile de comprendre.

0
Silas

Assurez-vous que vous vous connectez avec uniquement le nom d'utilisateur et non l'adresse e-mail complète que vous avez utilisée pour créer le compte (par exemple, si vous configurez [email protected], connectez-vous avec simplement admin).

Si vous avez des signes de ponctuation ou des caractères spéciaux dans votre mot de passe de connexion, cela posera un problème - mais dans la question du PO, vous utilisez un compte avec un mot de passe valide.

Selon les documents officiels :

  1. Réinitialisez ou ajoutez les informations d'administration dans la table ofproperty:

    DELETE FROM OFPROPERTY WHERE NAME='admin.authorizedJIDs';
    INSERT INTO OFPROPERTY VALUES('admin.authorizedJIDs','[email protected],[email protected]');
    

    Si vous utilisez la base de données intégrée, vous pouvez exécuter ces requêtes en modifiant embedded-db/openfire.script

  2. Ou ajoutez un autre administrateur au conf.xml.

    <admin>
        <authorizedJIDs>[email protected], [email protected]</authorizedJIDs>
    </admin>
    

    Basé sur cette page cependant, je soupçonne que ce paramètre a été renommé en <authorizedUsernames> au lieu de <authorizedJIDs>

  3. Vous pouvez également réexécuter la configuration , mais d'après mon expérience, cela n'a pas toujours aidé.

    edit /conf/openfire.xml and change the <setup> tag to false
    
  4. Pour être complet, d'autres ont répondu ci-dessus que vous pouvez modifier la table ofuser. [Je n'ai pas eu beaucoup de chance avec ça moi-même].

N'oubliez pas d'arrêter et de redémarrer openfire après avoir apporté des modifications, y compris l'exécution de la configuration. [Oui, je sais que c'est idiot. Faites-le quand même si vous voulez que OpenFire fonctionne.]

0
SamGoody

J'ai installé et désinstallé plusieurs fois sur Windows XP Machine Profesional SP3 utilisant la base de données intégrée d'Openfire 3.6.4. Impossible de me connecter à adminconsole. La dernière installation que j'ai redémarrée directement après l'installation et me permet Connecte-toi maintenant :)

J'espère que cela aide le sentiment frustrant de ne pas pouvoir se connecter pendant que vous venez de définir le mot de passe !! Étrange bug, cependant.

0
Wim

Si c'est sur Ubuntu 16.04, essayez d'utiliser le paquet debian "openfire_3.9.3_all" au lieu du dernier "openfire_4.1.0_all". Le dernier paquet est bogué pendant votre processus d'installation de remplissage des nouveaux détails de mot de passe. Ce problème n'est pas résolu. Mieux vaut utiliser la version précédente. Son travail bien.

0
Rajnesh Thakur

Je sais qu'il y a beaucoup de réponses, mais j'ai trouvé ma source de frustration après avoir changé le nom d'hôte du serveur dans openfire. La solution pour me permettre de me connecter:

  1. allez à sql et ouvrez la table ofProperty dans votre base de données openfire
  2. changer admin.authorizedJID de me @ oldhostname en me @ newhostname; séparez chaque utilisateur par une virgule
  3. Arrêtez Openfire, puis redémarrez-le - il chargera les administrateurs en mémoire

La désinstallation d'Openfire ne supprime probablement pas la base de données SQL, donc votre problème persistera. Vous pouvez également créer une nouvelle base de données et réinstaller dans la nouvelle base de données.

0
scape

Mon installation sur CentOS 5.3 a donné les mêmes résultats. Je ne parviens pas à me connecter en tant qu'administrateur après l'installation.

J'ai redémarré le serveur HTTP et Openfire. La connexion a été accordée après cela.

[[email protected] ~]# service httpd restart
Stopping httpd: [  OK  ]
Starting httpd: [  OK  ]

[[email protected] ~]# service openfire restart
Shutting down openfire:
Starting openfire:
0
xyz

J'ai eu le même problème avec 3.6.4, j'ai donc téléchargé 3.6.3 et cela fonctionne très bien.

Vous pouvez remplacer le "4" par un "3" dans le lien de téléchargement pour obtenir 3.6.3 ...

0
bjnortier

Je me suis connecté avec succès avec une configuration basée sur l'authentification LDAP avec le serveur MySQL. Je me suis connecté en tant que "admin" avec le mot de passe supposément mis à jour, qui est toujours "admin". J'espère que cela aide quelqu'un d'autre qui tire probablement ses cheveux comme moi.

P.S .: http://www.yosemitescouting.org/images/Yosemite%20Sam.bmp

0
shiny