it-swarm-eu.dev

Non concordance de version OpenSSL. Construit contre 1000105f, vous avez 10001080

Je viens de lancer apt-get upgrade, et selon /var/log/apt/history.log, openssl a été mis à jour vers la version 1.0.1e-2 + rvt + deb7u7. Maintenant, une session SSH est toujours ouverte, mais je ne peux pas en ouvrir une autre. J'ai redémarré SSH, qui a renvoyé OpenSSL version mismatch. Built against 1000105f, you have 10001080. J'ai essayé apt-get remove openssl && apt-get install openssl sans succès. J'exécute debian sur un Raspberry Pi.

Mise à jour: déplacé vers superutilisateur

10
Niek

Essayez apt-get install openssh-server openssh-client.

J'ai eu le même problème lorsque j'ai mis à jour mon système vers Debian Testing. Même si SSH était déjà installé, dans mon cas, il n'avait pas été mis à jour lors de l'exécution de apt-get update && apt-get upgrade et le système contenait donc les mêmes fichiers binaires SSH avec les bibliothèques désormais obsolètes liées à celui-ci, d'où l'absence de correspondance de version.

9
Milos Ivanovic

Assurez-vous que vos packages autre SSL ont le même numéro de version que votre package openssl. Des choses comme libssl1.0.0 et libssl-dev peuvent avoir une version supérieure ou inférieure si vous avez utilisé des dépôts non standard comme debian-testing.

Donc, si votre version openssl est, par exemple, 1.0.1e-2 + deb7u11, résoudre ce problème est aussi simple que 

apt-get install libssl1.0.0=1.0.1e-2+deb7u11
1
Cory Ringdahl

Assurez-vous également qu'aucun autre package installé n'a apporté sa propre bibliothèque openssl et ne s'est ajouté à votre environnement.

Un de ces coupables que je viens de trouver est le "Max View Storage Manager" de Microsemi. (Oui, je mentionne ce nom pour faire honte aux développeurs.) Il s’ajoute à:

  • LD_LIBRARY_PATH
  • PWD
  • OPENSSL_HOME
  • OPENSSL_BIN
  • CHEMIN

sSH a bien fonctionné en tant que root (où ces entrées supplémentaires n'ont pas été ajoutées) mais a échoué en tant qu'utilisateur normal.

0
dummzeuch

Je vais déconseiller la réponse ci-dessous car je viens de découvrir avec which ssh que j'utilise une version d'OpenSSH que j'ai compilée moi-même.

# which ssh
/usr/local/bin/ssh

Après la suppression de ma ssh locale, openssh-server et openssh-client ont été installés avec succès.


J'ai rencontré ce problème et utilisé la technique similaire à celle utilisée pour résoudre https://askubuntu.com/a/854145/348754 .

J'ai rencontré l'erreur suivante.

Creating SSH2 ECDSA key; this may take some time ...OpenSSL version mismatch. Built against 1000106f, you have 1000207f
dpkg: error processing package openssh-server (--configure):
 subprocess installed post-installation script returned error exit status 255

Je dois éditer /var/lib/dpkg/info/openssh-server.postinst et commenter les lignes suivantes.

#create_key "Creating SSH2 ECDSA key; this may take some time ..." \
#       "$hostkeys" /etc/ssh/ssh_Host_ecdsa_key -t ecdsa
#create_key "Creating SSH2 ED25519 key; this may take some time ..." \
#       "$hostkeys" /etc/ssh/ssh_Host_ed25519_key -t ed25519
0
f01

J'ai frappé cette erreur l'erreur suivante dans mon Ubuntu. 

OpenSSL version mismatch. Built against 100020bf, you have 1000106f

Voici ce que j'ai fait pour résoudre le problème.

  1. Vérifiez où est ssh

    \#which ssh
    
    /usr/local/bin/ssh
    
  2. Supprimez le paquet ssh actuel.

    Sudo apt-get remove openssh-server openssh-client
    
  3. Supprimez le fichier ssh sous/usr/local/bin/ssh

  4. Réinstallez le paquet ssh comme suit.

    Sudo apt-get install openssh-server openssh-client
    
  5. Déconnectez-vous de la session en cours et reconnectez-vous. La commande SSH est de retour au travail et se trouve sous/usr/bin/ssh.

    \#which ssh
    
    /usr/bin/ssh
    
0
csu007