it-swarm-eu.dev

Comment changer la version de PHP Apache2 utilise?

Ubuntu 10.04, MySQL 5.1, Apache 2.2 et PHP 5.2/5.3:

Je viens de découvrir que j'utilise la mauvaise version de PHP pour une application CRM. Une fois que j'ai compris comment créer un simple script phpinfo() pour me dire ce qu'Apache2 utilise , J'ai essayé de changer le php.ini De telle sorte que mon serveur Web utilise le PHP je veux. Eh bien, c'est mon problème. Je ne sais pas comment faire.

J'ai compilé la version de PHP Je veux /etc Ici:

/etc/php-5.2.8/

À l'intérieur de celui-ci, il y avait un fichier php.ini-recommended Dans lequel j'ai apporté des modifications et renommé php.ini Donc PHP l'utilisait. Mais quand j'ai ouvert mon navigateur et effacé mon historique et est allé à l'adresse http://localhost<CRM dir>/install.php, l'assistant dit toujours que je n'utilise pas la bonne version de PHP.

Basé sur cet article que dois-je faire pour changer la version de PHP qui apparaît après avoir exécuté mon script test.php? En d'autres termes , phpinfo() dit que j'exécute PHP 5.3.2, mais je veux le changer pour ma version 5.2.8 compilée située dans /etc.

26
nicorellius

Selon votre serveur, vous devriez regarder Apache, pas PHP.

(Pour RHEL/CentOS) regardez /etc/httpd/conf.d/php.ini

#
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated web pages.
#
LoadModule php5_module modules/libphp5.so
#
# Causes the PHP interpreter to handle files with a .php extension.
#
AddHandler php5-script .php
AddType text/html .php

Vous verrez que votre module PHP est modules/libphp5.so.

AddHandler php5-script .php indique à Apache d'exécuter PHP sur n'importe quel fichier avec l'extension .php.

Si vous utilisez un système d'exploitation basé sur RPM, il est probablement plus facile de désinstaller (en supposant que vous puissiez le faire) la version actuelle de PHP et de réinstaller la version que vous recherchez.

rpm -qa | grep php

vous montrera quelle version de PHP est actuellement installé.

8
grufftech

Si vous installez déjà une autre version de php, il vous suffit de changer le module php * utilisé par Apache.

par exemple, j'ai php5 et php7.0. quand je veux qu'Apache utilise php7.0, il me suffit d'activer son module et de désactiver le module php5.

Sudo a2dismod php5
Sudo a2enmod php7.0
42
hubert