it-swarm-eu.dev

Que signifie NT_STATUS_BAD_NETWORK_NAME dans Samba?

J'ai mis en place un partage comme celui-ci:

[global]
    security = user
    map to guest = Bad Password
    usershare allow guests = yes

[vms]
    comment = VirtualBox Virtual Machines
    path = /home/neil/VirtualBox/HardDisks
    guest ok = yes
    read only = yes

Et lorsque j'accède au partage en tant que moi-même et que je tape mon mot de passe, cela fonctionne très bien:

$ smbclient //neil-ubuntu/vms -U neil
Enter neil's password: 
Domain=[SHUTTERSTOCK] OS=[Unix] Server=[Samba 3.4.0]
smb: \>

Mais quand j'y accède en tant qu'invité, ça ne marche pas:

$ smbclient //neil-ubuntu/vms -U guest
Enter guest's password: 
Domain=[SHUTTERSTOCK] OS=[Unix] Server=[Samba 3.4.0]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

Quel que soit le mot de passe que je tape.

Quelqu'un sait-il pourquoi?

Aussi, pourquoi smbclient affiche-t-il de tels messages d'erreur inutiles?

16
Neil

Je me souviens d'un problème comme celui-ci. Je pense que cela a été causé par une autorisation de répertoire quelque part dans le chemin d'accès manquant de lecture. Vérifiez que les autorisations de répertoire sont 755 pour le chemin d'accès.

Cette erreur est également renvoyée si le chemin n'existe pas.

12
user9517

Je vais juste carillon ici avec un problème différent, mais le même message d'erreur. Si vous utilisez Samba <3.2, vous ne pouvez pas vous connecter aux serveurs Windows Server 2008 AD. Cela inclut la version de Samba incluse dans CentOS (et probablement RHEL) 5, actuellement Samba 3.0.23. En août 2011, la version actuelle de Samba est 3.6.

J'ai utilisé les référentiels Samba pour CentOS 5 hébergés par Sernet à http://www.enterprisesamba.org/index.php?id=125 pour installer Samba 3.4 et me connecter à un serveur Win 2008. N'oubliez pas d'installer/mettre à jour winbind (yum installez samba3-winbind après avoir ajouté le référentiel) et vous devrez peut-être mettre à jour /etc/krb5.conf (je viens de le déplacer vers un fichier /etc/krb5.conf.bak et autres) fonctionne bien).

J'ai également reçu Got NTLMSSP neg_flags=0x62898215 fréquemment dans les journaux smbclient.

1
jeffcook2150

essayez #Sudo smbpasswd -a guest

juste un coup là-bas. Si cela ne fonctionne pas, essayez d'ajouter "invité" à la ligne "utilisateurs valides" dans /etc/samba/smb.conf comme ceci,

valid users = user1, guest
0
chris