it-swarm-eu.dev

Comment vérifier la version avant d'installer des paquets en utilisant apt-get

Je pense installer hylafax + version 5.5.4, qui a été publiée le mois dernier sur mon Debian PC.

J'ai vérifié dpkg -l | grep "hylafax" et découvert que la version actuelle est 5.5.3. Ensuite, j'ai vérifié apt-cache search hylafax et vu que les paquets sont disponibles, mais je ne vois aucun numéro de version.

Comment trouver la version des packages disponibles dans le apt-get?

132
Yasiru G

OK, je l'ai trouvé.

apt-cache policy <package name> affichera les détails de la version.

Il indique également quelle version est actuellement installée et quelles versions sont disponibles pour être installées.

Par exemple, apt-cache policy hylafax+

228
Yasiru G

apt-cache policy <package-name>

$ apt-cache policy redis-server
redis-server:
  Installed: (none)
  Candidate: 2:2.8.4-2
  Version table:
     2:2.8.4-2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe AMD64 Packages

apt-get install -s <package-name>

$ apt-get install -s redis-server
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libjemalloc1 redis-tools
The following NEW packages will be installed:
  libjemalloc1 redis-server redis-tools
0 upgraded, 3 newly installed, 0 to remove and 3 not upgraded.
Inst libjemalloc1 (3.5.1-2 Ubuntu:14.04/trusty [AMD64])
Inst redis-tools (2:2.8.4-2 Ubuntu:14.04/trusty [AMD64])
Inst redis-server (2:2.8.4-2 Ubuntu:14.04/trusty [AMD64])
Conf libjemalloc1 (3.5.1-2 Ubuntu:14.04/trusty [AMD64])
Conf redis-tools (2:2.8.4-2 Ubuntu:14.04/trusty [AMD64])
Conf redis-server (2:2.8.4-2 Ubuntu:14.04/trusty [AMD64])

apt-cache show <package-name>

$ apt-cache show redis-server
Package: redis-server
Priority: optional
Section: universe/misc
Installed-Size: 744
Maintainer: Ubuntu Developers <[email protected]>
Original-Maintainer: Chris Lamb <[email protected]>
Architecture: AMD64
Source: redis
Version: 2:2.8.4-2
Depends: libc6 (>= 2.14), libjemalloc1 (>= 2.1.1), redis-tools (= 2:2.8.4-2), adduser
Filename: pool/universe/r/redis/redis-server_2.8.4-2_AMD64.deb
Size: 267446
MD5sum: 066f3ce93331b876b691df69d11b7e36
SHA1: f7ffbf228cc10aa6ff23ecc16f8c744928d7782e
SHA256: 2d273574f134dc0d8d10d41b5eab54114dfcf8b716bad4e6d04ad8452fe1627d
Description-en: Persistent key-value database with network interface
 Redis is a key-value database in a similar vein to memcache but the dataset
 is non-volatile. Redis additionally provides native support for atomically
 manipulating and querying data structures such as lists and sets.
 .
 The dataset is stored entirely in memory and periodically flushed to disk.
Description-md5: 9160ed1405585ab844f8750a9305d33f
Homepage: http://redis.io/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubunt

dpkg -l <package-name>

$ dpkg -l nginx
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                     Version                   Architecture              Description
+++-========================================-=========================-=========================-=====================================================================================
ii  nginx                                    1.6.2-1~trusty            AMD64                     high performance web server
27
Anthony Zhan
apt policy <package>

pour faire court

8
P. Vincent

Ce qui suit pourrait fonctionner assez bien:

aptitude versions ^hylafax+

Voir plus dans aptitude (8)

6
Onlyjob

De plus, le paquet apt-show-versions (installé séparément) analyse les informations de dpkg sur ce qui est installé et vous indique si les paquetages sont à jour.

Exemple..

$ Sudo apt-show-versions --regex chrome
google-chrome-stable/stable upgradeable from 32.0.1700.102-1 to 35.0.1916.114-1
xserver-xorg-video-openchrome/quantal-security uptodate 1:0.3.1-0ubuntu1.12.10.1
$
3
HeyWatchThis

sur debian:

apt list --upgradable

donne la liste avec le paquet, la version à mettre à jour et la version actuelle du paquet.

résultat : 

base-files/stable 8+deb8u8 AMD64 [upgradable from: 8+deb8u7]
bind9-Host/stable 1:9.9.5.dfsg-9+deb8u11 AMD64 [upgradable from: 1:9.9.5.dfsg-9+deb8u9]
ca-certificates/stable 20141019+deb8u3 all [upgradable from: 20141019+deb8u2]
certbot/jessie-backports 0.10.2-1~bpo8+1 all [upgradable from: 0.8.1-2~bpo8+1]
dnsutils/stable 1:9.9.5.dfsg-9+deb8u11 AMD64 [upgradable from: 1:9.9.5.dfsg-9+deb8u9]
2
Trantkat Troy

Linux Mint, Debian 9, Ubuntu 16.04 et plus ancienne:

Info courte :

apt policy <package_name>

Informations détaillées (avec description et dépend):

apt show <package_name>
1
mature

En outre, selon la page de manuel:

apt-cache showpkg <package_name>

peut également être utilisé pour:

... afficher des informations sur les packages répertoriés sur la ligne de commande. Les arguments restants sont package des noms. Les versions disponibles et les dépendances inverses de chaque package répertorié sont répertoriées, ainsi que la transmission dépendances pour chaque version. Les dépendances en aval (normales) sont les paquetages sur lesquels le paquet se trouve la question dépend; les dépendances inverses sont les paquets qui dépendent du paquet en question. Ainsi, les dépendances de transfert doivent être satisfaites pour un package, mais les dépendances inverses ne doivent pas nécessairement l'être.

Ex:

apt-cache policy conky

conky:
  Installed: (none)
  Candidate: 1.10.3-1
  Version table:
     1.10.3-1 500
        500 http://us.archive.ubuntu.com/ubuntu yakkety/universe AMD64 Packages
        500 http://us.archive.ubuntu.com/ubuntu yakkety/universe i386 Packages
1
kjones

Comme indiqué ailleurs, cela fonctionne aussi:

apt-cache madison <package_name>

0
woohoo

Vous pouvez également simplement effectuer les opérations habituelles apt-get update puis, comme indiqué dans le manuel, procédez comme suit:

apt-get -V upgrade

-V Afficher les numéros de version commentés

Ce qui vous montrera le paquet actuel par rapport à celui qui sera mis à jour dans un format similaire à celui-ci:

_~# Sudo apt-get -V upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
   curl (7.38.0-4+deb8u14 => 7.38.0-4+deb8u15)
   php5 (5.6.40+dfsg-0+deb8u2 => 5.6.40+dfsg-0+deb8u3)
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.0 MB of archives.
After this operation, 567 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
_
0
Frankie