it-swarm-eu.dev

Comment télécharger un paquet avec des dépendances sur mon PPA?

J'ai fait un paquet pour mon PPA et l'ai téléchargé. Il a construit sans aucun problème.

Ensuite, j'ai fait un autre paquet qui dépendait du premier et je l'ai téléchargé. Il a échoué car il n'a pas pu trouver les fichiers du premier paquet. Cela me porte à croire que le premier paquet n'a même pas été installé.

Comment puis-je m'assurer que le premier package est installé avant d'essayer de générer le second package?

Le fichier de contrôle du premier package (libjsoncpp):

 Source: jsoncpp 
 Priorité: extra 
 Responsable de la maintenance: Nathan Osman 
 Compilation des dépendances: debhelper (> = 7) 
 Normes - Version: 3.8 .3 Section 
: Libs 
 Page d'accueil: http://jsoncpp.sf.net 
 
 Paquetage: jsoncpp-dev 
 Section: libdevel 
 Architecture: any 
 Dépend de: libjsoncpp (= $ {binary: Version}) 
 Description: bibliothèque d'analyse syntaxique JSON pour C++ 
 Jsoncpp est une bibliothèque C++ qui facilite la tâche. to 
 lire/écrire des données JSON. 
. 
 Ce paquet contient les outils de développement nécessaires 
 pour créer des applications utilisant jsoncpp. 
 
 Paquetage: libjsoncpp 
 Section: libs 
 Architecture: tout 
 Dépend: $ {shlibs: Dépend}, $ {misc: Dépend} 
 Description: Analyse JSON bibliothèque pour C++ 
 jsoncpp est une bibliothèque C++ facilitant la lecture/écriture de données JSON 
. 

Le fichier de contrôle pour le second (libsopp):

 Source: sopp 
 Priorité: extra 
 Responsable de la maintenance: Nathan Osman 
 Compilation des dépendances: debhelper (> = 7) 
 Normes - Version: 3.8 .3 Section 
: Libs 
 Page d'accueil: http://stackoverflow.quickmediasolutions.com 
 
 Package: sopp-dev 
 Section: libdevel 
 Architecture: any 
 Dépend de: libsopp (= $ {binary: Version}), jsoncpp-dev 
 Description: une bibliothèque C++ pour l’interfaçage avec des sites StackExchange. 
 So ++ est une bibliothèque C++ qui englobe les fonctionnalités de l'API StackOverflow 
. Il donne accès à tous les sites StackExchange. 
. 
 Ce paquet contient les fichiers de développement nécessaires pour écrire un logiciel 
 Qui utilise so ++. 
 
 Paquetage: libsopp 
 Section: libs 
 Architecture: quelconque 
 Dépend: $ {shlibs: Depends}, $ {misc: Depends}, libjsoncpp 
 Description: C++ Bibliothèque pour l'interfaçage avec les sites StackExchange. 
 so ++ est une bibliothèque C++ qui englobe les fonctionnalités de l'API StackOverflow 
. Il donne accès à tous les sites StackExchange. 
13
Nathan Osman

Votre deuxième paquet (sopp) doit spécifier qu'il a besoin du premier à build; la dépendance que vous avez spécifiée (avec Depends:) ne gérera que l'installation.

Pour ajouter une dépendance de construction, ajoutez ceci en haut de la section (Source:) de votre fichier de contrôle:

Build-Depends: jsoncpp-dev

Vous devriez alors pouvoir supprimer jsoncpp de la ligne Depends, comme la macro shlibs:Depends devrait le résoudre lui-même.

10
Jeremy Kerr