it-swarm-eu.dev

Erreur de publication: impossible de charger le fichier ou l'assembly 'Microsoft.Web.XmlTransform', version = 1.4.0.0, Culture = neutre, etc. ou l'une de ses dépendances

Je veux publier un projet MVC et je continue à avoir cette erreur: 

System.IO.FileNotFoundException: impossible de charger le fichier ou l'assembly 'Microsoft.Web.XmlTransform', version = 1.4.0.0, Culture = neutre, PublicKeyToken = ... ou l'une de ses dépendances. Le système ne peut pas trouver le fichier spécifié.

J'ai cherché et essayé certaines solutions trouvées sur SO ou MSDN, mais en vain. Je suis vraiment désespéré de quelques suggestions ..__ Le projet a été publié avec succès auparavant, mais cela est sorti de nulle part après avoir essayé de republier ma version mise à jour.

22
barca_d

J'ai finalement obtenu que cela fonctionne. Je laisse ma solution ici au cas où d'autres auraient un problème similaire.

En gros, j'ai essayé de réparer mon VS à l'aide de Microsoft ASP.NET et des outils Web 2013.1 (je l'ai eu ici page de téléchargement des outils Web Microsoft ). Cependant, cela ne résout pas le problème pour moi… .. Ce qui a été résolu, c’est de copier le fichier Microsoft.Web.XmlTransforms.dll depuis un autre ordinateur de l’emplacement. 

C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Web

D'une manière ou d'une autre, le mien avait disparu de là (je l'ai reçu d'un autre ordinateur avec la même version .NET et je l'ai collé là) et maintenant, la publication fonctionne bien.

18
barca_d

La réparation de "Microsoft ASP.NET et outils Web 2013.1 - Visual Studio 2012" à partir du Panneau de configuration a rajouté la dll pour moi (ce qui manquait, apparemment après avoir mis à jour ledit paquet il y a quelques semaines).

18
Piedone

La réparation de MS Web Tools pour VS2012 n'a pas résolu le problème.

J'ai les fichiers dans le dossier C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\Web (je ne sais pas si c'est parce que j'ai installé VS 2013 Express ou un autre outil. L'installation des Outils Web pour VS 2013 les créera peut-être) 

La copie des fichiers du dossier v12.0 vers le dossier v11.0 a résolu le problème. 

3
d.popov

Avait ce problème aussi. Ce qui a fonctionné pour moi a été:

3
bicycle

exécuter VS12 en mode administrateur m'a aidé après avoir essayé tout recommandé ci-dessus

1
Andriy Ivaskevych

Réinstallez le package NuGet Microsoft.Web.Xdt

0
opis-kladno

Avez-vous déjà essayé d’utiliser la visionneuse de journal d’assemblage, cela pourrait vous donner plus d’informations ...

http://msdn.Microsoft.com/en-us/library/e74a18c4(v=vs.110).aspx

0
Justin Harvey

J'ai eu un problème presque identique, à l'exception de la publication qui disait qu'il ne pouvait pas trouver Newtonsoft.Json.dll, Version = 4.5.0.0. J'ai essayé toutes les solutions ci-dessus avant de réaliser que le fichier manquait dans le répertoire package d'Azure WebJobs Publish (toutes mes excuses pour ne pas avoir le nom complet du package à portée de main). La solution consistait simplement à vider tout mon dossier/packages/et à les laisser restaurer automatiquement.

0
pbarranis

Téléchargez le fichier à partir d'ici: https://docs.google.com/file/d/0B8XrlgnW-cfISXd1Q0VQb0gtNk0/edit

et placez-le ici: C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\Web

Prendre plaisir !

0
user2626270

Ma situation semble avoir été provoquée lorsque j'ai installé le SDK Azure 1.1 et les composants de Service Bus pour Windows. La publication dans Azure échouait sans cesse pour les erreurs de transformation, retournait à certains de mes autres projets qui n'étaient que des installations de packages Web et, une fois encore, ces transformations échouaient pour la même erreur. J'ai donc un problème plus grave. Mon POC rompt maintenant mes déploiements en production . J'ai supprimé et réinstallé Microsoft ASP.Net et WebTools 2013.v - Visual Studio 2012 à partir du panneau de configuration, ce qui n'a pas aidé. Redémarrage de la machine et ensuite juste une réparation sur le même composant, et voilà, semble fonctionner correctement maintenant.

0
JMAC

J'espère que ma solution aiderait quelqu'un.

Il y avait un programme installé appelé "Microsoft ASP.NET and Framework 2012.2", Désinstaller-le puis réparer Microsoft Visual Studio Professional 2012, fonctionne correctement maintenant

Programmes installés (Panneau de configuration -> Programmes et fonctionnalités)

Microsoft .NET Framework 4.5

Microsoft ASP.NET MVC 3

Pages Web Microsoft ASP.NET

Microsoft Visual Studio Professional 2012 avec la mise à jour 5

Microsoft Web Deploy 3.5

0
Feng

Pour moi, la solution 'barca_d' a fonctionné mais je devais aussi garder mes projets 

0
MaRK