it-swarm-eu.dev

Comment contourner le problème "Release file expired" sur un miroir local

J'ai un miroir local (créé avec debmirror), et quand je lance apt-get update après quelques jours, j'obtiens ceci:

E: Release file expired, ignoring file:/home/wena/.repo_bin/dists/sid/Release (invalid since 14h 31min 45s)

Comment contourner cela?

71
tshepang

Ajoutez ceci à la commande:

-o Acquire::Check-Valid-Until=false

Par exemple:

Sudo apt-get -o Acquire::Check-Valid-Until=false update
110
A A

Si vous ne vous souciez pas de cette vérification, quel que soit le miroir, créez simplement un fichier dans /etc/apt/apt.conf.d/ (par exemple, nommez-le 10no--check-valid-until) et mettez l'option directement dedans:

Acquire::Check-Valid-Until "0";

Après cela, vous ne serez plus jamais dérangé par l'avertissement mentionné.

40
Jaleks

Les fichiers de version ont une entrée valide jusqu'à, par exemple Valid-Until: Thu, 07 Oct 2010 08:17:56 UTC

Si le fichier de version n'est plus valide, vous devez réexécuter debmirror pour vérifier s'il y a des modifications dans le référentiel. Une modification sera le fichier de version et vous obtiendrez une nouvelle validité pour celui-ci.

Vous pouvez facilement automatiser cela avec une entrée crontab.

11
echox

Cela peut également se produire si la date/heure de votre système est incorrecte. Je l'ai corrigé en corrigeant mon heure locale avant de faire la mise à jour.

6
MarrekNožka

Je ne sais pas si cela est lié au problème actuel de Jessie ( https://lists.debian.org/debian-devel-announce/2019/03/msg00006.html ) ou non. mais pour ceux qui ont une même erreur déjà utilisée

Sudo apt-get -o Acquire::Check-Valid-Until=false update

et toujours eu un même problème, vous pouvez essayer ceci à la place

echo 'Acquire::Check-Valid-Until no;' > /etc/apt/apt.conf.d/99no-check-valid-until

Ça marche pour moi :)

4
Alex Chandra

Certains miroirs peuvent contenir des fichiers périmés. Cela m'est arrivé récemment et c'était également lié au serveur de mise en cache que j'utilise (apt-cacher-ng) qui essaie d'économiser de la bande passante en redirigeant les référentiels de la même archive vers une seule entité (dans mon cas, si c'était un Miroir hongrois). Les mises à jour directes via le miroir allemand ont bien fonctionné, par exemple. Essayez de changer le miroir que vous utilisez. Si vous utilisez apt-cacher-ng, vous devrez faire quelque chose dans la ligne de modification du contenu du fichier suivant:

  • / etc/apt-cacher-ng/backends_debian
  • / etc/apt-cacher-ng/backends_debvol

Après cela, vous devez également redémarrer apt-cacher-ng pour que les modifications prennent effet.

3
user4973

J'ai enlevé /var/lib/apt/* et relancez apt-get update, et il fonctionne!

2
Patrick

Le miroir n'est peut-être pas expiré.

Plutôt quelque chose d'autre sur votre système pourrait être foiré. Essaye ça:


1) Mettez temporairement en commentaire les lignes liées de /etc/apt/sources.list, ou /etc/apt/source.list.d/*. Par exemple, après avoir commenté les deux lignes suivantes, mon erreur a disparu (avec pour conséquence que ces archives n'ont temporairement pas été utilisées pour les rechargements):

deb http://security.debian.org/ stretch/updates non-free contrib main
deb http://mirrors.ocf.berkeley.edu/debian/ stretch-updates main contrib non-free

2) Ouvrez synaptique et rechargez, ou probablement Sudo apt-get update fonctionnerait également.

3) Remettez ces lignes en commentaire.

4) Répétez l'étape 2.


A corrigé cela pour moi. Je suppose que mon cache d'apt a une mauvaise date.

Mon problème s'est produit après la restauration de mes systèmes de fichiers/(root) et/var à partir d'instantanés btrfs pour aider à résoudre un problème d'installation de package qui s'est produit. Le message d'erreur exact que je recevais était:

Le fichier de sortie pour http://mirrors.ocf.berkeley.edu/debian/dists/stretch-updates/InRelease est expiré (invalide depuis 5j 4h 50min 18s). Les mises à jour de ce référentiel ne seront pas appliquées. Le fichier de version pour http://security.debian.org/dists/stretch/updates/InRelease est expiré (invalide depuis 2j 2h 52min 43s). Les mises à jour de ce référentiel ne seront pas appliquées.

0
Elliptical view