it-swarm-eu.dev

Firmware-Update für iPod Touch (iPhone)?

Ich muss die Firmware meines iPod Touch (iPhone) in Ubuntu aktualisieren und da ich einen iPod Touch mit Jailbreak habe, benötige ich iTunes, um Apps zu installieren, habe aber leider noch keine Möglichkeit gefunden, dies in Ubuntu zu tun. Ich weiß, dass es möglich ist, VirtualBox oder Wine zu verwenden, aber in den meisten Fällen möchte iTunes nicht mit Wine arbeiten und für VirtualBox muss ich das Windows, von dem ich vor ein paar Monaten zu Ubuntu gewechselt bin, erneut installieren und möchte nicht darauf zurückgreifen.

Was tun Linux-Benutzer mit einem iPod Touch (iPhone) in diesem Fall?

Anregungen zur Lösung des Problems werden gerne entgegengenommen.

Und wie lange wird es dauern, bis Apple iTunes für Linux entwickelt?

18
Bakhtiyor

Einige ältere Versionen von iTunes können derzeit für die Verwendung mit Wine (oder Crossover) konfiguriert werden. Sie können jedoch nicht zum Aktualisieren oder Synchronisieren neuer iPods verwendet werden.

Der Grund dafür ist, dass Wine keinen Handler für Windows-USB-Gerätetreiber hat und der iPod als benutzerdefiniertes USB-Gerät fungiert. Dies ist der gleiche Grund, warum Software, die einen speziellen Schlüssel-Dongle benötigt, (noch) nicht in Wine funktioniert. Hierfür stehen einige vorläufige Patches zur Verfügung. Weitere Informationen finden Sie im Wein-Wiki . Erwarten Sie jedoch, dass nichts funktioniert.

Die einzigen iPods, die derzeit in Wine funktionieren, sind wirklich alte iPods, die als einfache USB-Massenspeichergeräte fungieren. Und selbst dann müssen Sie noch ein älteres, funktionierendes iTunes finden.

Aufgrund dieses Problems in Wine müssen Sie für das Firmware-Upgrade entweder eine virtuelle Maschine mit Virtualbox oder VMware einrichten oder einfach den Computer einer anderen Person ausleihen.

9
Scott Ritchie

Ich weiß nicht, ob dies mit Ihrem iPod touch funktioniert, aber es funktioniert mit meinen älteren iPods: http://code.google.com/p/iPod-update/

4
manyxcxi

Betrachtet man die CrossoverSeite für iTunes , wurde berichtet, dass einige Versionen etwas funktionieren. Crossover kostet Geld, aber es kann sich für Sie lohnen.

3

Firmware-Upgrade hat bei mir nicht funktioniert: Ubuntu 8.04 LTS mit vmplayer und einem alten XP mit iTunes.

Keine Chance. Das iPhone war für den Rest des Tages außer Betrieb, bis ich es auf meiner Jobseite an meinen Windows-PC anschloss.

Aus dieser Sicht: Apple-Produkte sind ein absolutes No-Go! Warum brauche ich ein Windows oder einen Mac mit iTunes, um ein Telefon zu haben? Wo steht, dass ich beim Kauf dieses "Dingsbums" ein laufendes iTunes brauche, damit es funktioniert? Wer kennt die Kosten schon?

3
Ice

libimobiledevice

Es ist immer noch experimentell, aber Sie sollten libimobiledevice überprüfen. Derzeit gibt es noch keine grafische Benutzeroberfläche, sie arbeiten jedoch daran, iPod touch-Modelle für Linux (einschließlich Software-Up- und -Downgrades) zu optimieren.


Edit: Laut buntu Wiki ist dies die Standardeinstellung seit mindestens 14.04 und in verschiedenen Projekten implementiert. Überprüfen Sie die Nachrichten und den Status auf der libimobiledevice-Projektseite für Details. Derzeit behaupten sie, dass sie iOS 9 unterstützen, das sich zum Zeitpunkt des Schreibens noch in der Beta befand.

2
PierreS

Ich war müde, meine iPhone-Firmware von Version 2 auf Version 3 mit iTunes zu aktualisieren, das in VMware ausgeführt wird. Der Prozess wurde mitten im Stream angehalten und das iPhone wurde unbrauchbar gemacht. Ich habe es an die Windows-Computer eines Freundes angeschlossen und nach mehreren Aktualisierungsversuchen ist es wieder zum Leben erweckt worden.

Updates mit den gleichen Hauptversionen funktionierten in iTunes/VMware jedoch einwandfrei.

0
A.B.