it-swarm-eu.dev

Gebietsschema: Verlorene Einstellungen zurücksetzen

Aus irgendeinem seltsamen Grund habe ich einige meiner locale Einstellungen verloren. Ich habe es geschafft, die meisten von ihnen mit Sudo dpkg-reconfigure locales wiederherzustellen:

Perl: warning: Setting locale failed.
Perl: warning: Please check that your locale settings:
 LANGUAGE = (unset),
 LC_ALL = (unset),
 LANG = "en_US.UTF-8"
    are supported and installed on your system.
Perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Also stecke ich mit einem fehlenden Wert fest:

$ locale
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Irgendeine Idee, wie man sie alle wieder herstellt?

Vielen Dank,

Adam

6
Adam Matan

Falls Sie einige Dateien gelöscht haben, installieren Sie das Gebietsschema-Paket erneut:

apt-get install --reinstall locales

Möglicherweise möchten Sie dasselbe für die Sprachunterstützung (Ihr Langcode), das Sprachpaket (Ihr Langcode) und andere Sprachpakete (Gnome, KDE ...) für Ihre Sprache tun.

5
Xuacu

Passiert mir gelegentlich auch. Ich bin mir nicht sicher, was es verursacht, aber ich schieße einfach ab:

Sudo dpkg-reconfigure locales

Und das scheint es zu beheben (für mich)

8
Oli

Folgendes musste ich tun, um das zu beheben:

Sudo apt-get install --reinstall language-support-en
5
Eric Johnson

Eine der gegebenen Antworten hat mir nicht geholfen, aber ich fand Folgendes:

http://ubuntuforums.org/showpost.php?p=12183173&postcount=6

und es hat den Trick gemacht.

2
Irek

Von Zeit zu Zeit stoße ich auf dieses Problem, und keine der oben genannten Antworten hilft mir. Was mir tatsächlich hilft, ist das Hinzufügen des Folgenden zu/etc/default/locales

LANG="en_US.UTF-8"
LANGUAGE="en_US"
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=en_US.UTF-8
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES=en_US.UTF-8
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
1
Artem Pakk