it-swarm-eu.dev

Was könnte Mausbewegungen zwischen xrandr-Bildschirmen verhindern?

Ich habe die in diesem HowTo beschriebenen Schritte befolgt.

Direkt nachdem ich mich bei Gnome angemeldet habe, kann ich die Maus hin und her bewegen, aber sobald die Taskleiste geladen wird, bleibt die Maus auf dem Bildschirm hängen (kann nicht zwischen den Bildschirmen wechseln).

Das ist meine xorg.conf:

 Section "ServerLayout"
            Identifier     "Layout0"
            Screen      0  "DisplayLinkScreen" 0 0
            Screen   1  "Screen0" LeftOf "DisplayLinkScreen"
            InputDevice    "Keyboard0" "CoreKeyboard"
            InputDevice    "Mouse0" "CorePointer"
            Option     "Xinerama" "0" #Could not get this to work it has to be disable
EndSection

Section "Files"
 ModulePath   "/usr/local/lib/xorg/modules/drivers"
 ModulePath      "/usr/lib/xorg/modules/drivers"
 ModulePath      "/usr/local/lib"

 ModulePath   "/usr/lib/xorg/modules"
 FontPath     "/usr/share/fonts/X11/misc"
 FontPath     "/usr/share/fonts/X11/cyrillic"
 FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath     "/usr/share/fonts/X11/Type1"
 FontPath     "/usr/share/fonts/X11/100dpi"
 FontPath     "/usr/share/fonts/X11/75dpi"
 FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
 FontPath     "built-ins"
EndSection

Section "Module"
 Load  "dbe"
 Load  "dri"
 Load  "dri2"
 Load  "extmod"
 Load  "glx"
 Load  "record"
EndSection

Section "InputDevice"
 Identifier  "Keyboard0"
 Driver      "kbd"
EndSection

Section "InputDevice"
 Identifier  "Mouse0"
 Driver      "mouse"
 Option     "Protocol" "auto"
 Option      "Device" "/dev/psaux" 
 # Option     "Device" "/dev/input/mice"
 Option     "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
 Identifier   "Monitor0"
 VendorName   "Monitor Vendor"
 ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"             # [<bool>]
        #Option     "SWcursor"            # [<bool>]
        #Option     "ColorKey"            # <i>
        #Option     "CacheLines"          # <i>
        #Option     "Dac6Bit"             # [<bool>]
        #Option     "DRI"                 # [<bool>]
        #Option     "NoDDC"               # [<bool>]
        #Option     "ShowCache"           # [<bool>]
        #Option     "XvMCSurfaces"        # <i>
        #Option     "PageFlip"            # [<bool>]
 Identifier  "Card0"
 Driver      "intel"
 VendorName  "Intel Corporation"
 BoardName   "Core Processor Integrated Graphics Controller"
 BusID       "PCI:0:2:0"
 Option     "DPMS"
EndSection

Section "Screen"
 Identifier "Screen0"
 Device     "Card0"
 Monitor    "Monitor0"
 SubSection "Display"
  Viewport   0 0
  Depth     1
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     4
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     8
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     15
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     16
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     24
 EndSubSection
EndSection

Section "Monitor"
    Identifier     "DisplayLinkMonitor"
EndSection
Section "Device"
    Identifier  "DisplayLinkDevice"
    Driver  "displaylink"
    Option   "fbdev" "/dev/fb0"
EndSection
Section "Screen"
    Identifier      "DisplayLinkScreen"
    Device          "DisplayLinkDevice"
    Monitor         "DisplayLinkMonitor"
    SubSection "Display"
        Depth       24
        Modes       "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1366x768" "1280x1024" "1280x960" "1280x800"  "1280x768"  "1152x864" "1024x768" "800x600" "640x480" 
    EndSubSection
EndSection

Jede Hilfe wäre dankbar. Ich bin so nah dran, das zum Laufen zu bringen!

10
Tyler

Ich vermute hier, dass die Position des rechten Bildschirms die Probleme verursacht. Sie können versuchen, den Abschnitt ServerLayout wie folgt zu ändern:

Section "ServerLayout"
        Identifier     "Layout0"
        Screen         0 "Screen0" 0 0
        Screen         1 "DisplayLinkScreen" RightOf "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
EndSection

Wenn Sie wirklich möchten, dass der DisplayLinkScreen der primäre Bildschirm ist, ändern Sie ihn so, dass die Koordinaten mit der Auflösung von Screen0 übereinstimmen. Zum Beispiel hat Screen0 eine Auflösung von 1900x1200:

Section "ServerLayout"
        Identifier     "Layout0"
        Screen         0  "DisplayLinkScreen" 1900 0
        Screen         1  "Screen0" LeftOf "DisplayLinkScreen"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
EndSection

Ein weiterer möglicher Ort für die Probleme könnte in der RandR-Konfiguration liegen, die beim Start von gnome geladen wird. Sie können die RandR-Konfiguration vollständig zurücksetzen, indem Sie ~/.config/monitors.xml Löschen.

6
Ressu

Ich habe ein Tool gefunden hier , das die Maus automatisch zwischen getrennten Bildschirmen einhüllt.

Es hat bei mir funktioniert, als ich Probleme hatte, die Maus zwischen den Bildschirmen hin und her zu bewegen.

4
Nathan Osman

Sie haben zwei verschiedene Grafikgeräte, eines mit -intel und eines mit -displayport, und möchten diese zusammenfügen, damit sich die Maus nahtlos über sie bewegt. Mit Xinerama werden mehrere Bildschirme zusammengefügt, daher muss dies aktiviert sein.

Der Xinerama-Modus für -intel wird jedoch nicht wirklich gut unterstützt (sollte aber besser werden). Vielleicht haben Sie Glück damit, aber meines Wissens ist nicht zu erwarten, dass dies funktioniert.

Sie können es wahrscheinlich zum Laufen bringen, wenn Sie den proprietären Binärtreiber -nvidia verwenden.

2
Bryce