it-swarm-eu.dev

Leerer Bildschirm, blinkender Cursor beim Booten

Gelegentlich bootet mein Ubuntu 10.04-PC nicht richtig. Es kommt an Grub vorbei und stoppt dann bei einem leeren Bildschirm und einem blinkenden Cursor. Nach dem, was ich gelesen habe, wird dieser blinkende Cursor-Bildschirm von Ubuntu selbst und nicht von Grub dargestellt, daher gehe ich davon aus, dass der Startvorgang aus irgendeinem Grund angehalten wird. Hat jemand eine Anleitung, wie man dieses Problem diagnostiziert oder was die Ursache sein könnte? Normalerweise muss ich die Reset-Taste drücken, um den PC neu zu starten. Die Tatsache, dass es intermittierend ist, ist das, was mich verwirrt.

Alle Hinweise zur Diagnose des Problems wäre sehr dankbar.


Bearbeiten:

Es ist schon eine Weile her, vor allem, weil mein Server schon lange nicht mehr funktioniert hat. Es sieht so aus, als hätte ich eine Wiederholung dieses Problems aufgezeichnet. Ich habe die messages -Datei und die dmesg -Datei kopiert und einen Blick darauf geworfen, wo die Verarbeitung gestoppt zu sein scheint und die folgenden Meldungen gefunden. Ich werde etwas über Google usw. recherchieren, aber ich habe mir gedacht, dass ich es hier aufstellen würde, falls jemand helfen kann und sich ein paar Punkte verdienen möchte. Ich sollte erwähnen, dass die Meldung ondemand governor failed bei erfolgreichen Starts auftritt, die anderen beiden jedoch nicht angezeigt werden.

Oct 11 23:17:21 linux kernel: [   98.905370] ondemand governor failed, too long transition latency of HW, fallback to performance governor  
Oct 11 23:21:48 linux kernel: Kernel logging (proc) stopped.  
Oct 11 23:21:48 linux rsyslogd: [Origin software="rsyslogd" swVersion="4.2.0" x-pid="697" x-info="http://www.rsyslog.com"] exiting on signal 15. 

Ich fand ein paar vage Hinweise auf das Überschreiben von Protokolldateien beim Booten als Ursache

21
conorgriffin

Halten Sie die Umschalttaste während des Startvorgangs gedrückt und drücken Sie dann e, um den Eintrag GRUB zu bearbeiten. Entfernen Sie den Teil mit der Aufschrift "Silent Splash" und ersetzen Sie ihn durch "Text", um zu sehen, was während des Startvorgangs passiert.

22
maco

In meinem Fall war der blinkende Cursor alles, was ich jemals bekommen würde. Kein boot Es war nach der Installation eines neuen Ubuntu Minimal. Ich habe herausgefunden, dass während des GRUB Installationsschritts GRUB auf dem falschen Laufwerk, dem "ersten" Laufwerk (/ dev/sda), installiert wurde.

Mein System verfügt über 3 Laufwerke. Zwei 500-GB-Festplatten in RAID, die ich während der Installation nicht berühren wollte, und eine 120-GB-SSD, die ich für das Betriebssystem verwende. Aus irgendeinem Grund ist das "erste Laufwerk" (/ dev/sda) eines meiner 500-GB-Laufwerke./dev/sdb ist mein 120 GB-Laufwerk und/dev/sdc ist das andere 500 GB-Laufwerk.

Beim Formatieren mit einer Partitionstabelle von "mbr" auf meinem 120-GB-Laufwerk habe ich also die normalen 117 GB bootfähiges ext4 und 3 GB Swap ausgeführt. Wählen Sie im Installationsschritt GRUB NICHT Ja, um GRUB auf das "erste" Laufwerk zu kopieren. Wählen Sie NEIN. Dies öffnet einen weiteren Bildschirm, in dem Sie/dev/sdX eingeben können. In meinem Fall habe ich/dev/sdb und/dev/sdb1 ausprobiert, aber das Installationsprogramm gab mir jedes Mal einen schwerwiegenden Fehler, der immer noch keinen Sinn ergibt.

Schließlich musste ich mein 120-GB-Laufwerk mit einer Partitionstabelle von "gpt" formatieren. Mit GPT müssen Sie manuell eine GRUB Partition erstellen. So geht das mit GPT. Die erste Partition, die ich für GRUB erstellt habe, war 32,0 MB groß und für "boot or something (vergiss die Formulierung)" formatiert. Zweite Partition war meine 3.0 GB formatiert für "Swap", am "Ende". Die dritte Partition war der verbleibende Speicherplatz, der als "ext4" formatiert war.

Wenn Sie nun im Installationsschritt GRUB NO auswählen, geben Sie/dev/sdb manuell ein, nicht überraschend/dev/sdb1, und es funktioniert dann. GRUB wird in die 32-MB-Startpartition auf dem richtigen Laufwerk installiert und das System wird normal gestartet. YAY!

Übrigens müssen Sie zu Beginn der Installation im Menü die Option "Experteninstallation" auswählen und die Festplatte "manuell" und nicht "geführt" formatieren. Guided wählt immer/dev/sda als erstes Laufwerk und der blinkende Cursor/no boot führt dazu, wenn/dev/sda nicht Ihr Betriebssystemlaufwerk ist.

3

Ich habe dieses Problem schon einige Male gehabt, aber ich konnte mindestens drei verschiedene Varianten unterscheiden:

  • setzt den Start nach Drücken der Eingabetaste fort
  • fährt nach einer Weile mit dem Booten fort, ohne etwas zu tun
  • setzt den Startvorgang nie fort, akzeptiert jedoch Strg-Alt-Entf, was darauf hinweist, dass der Kernel noch einige Leben hat

Dies hat mich zu der Annahme gebracht, dass das eigentliche Problem darin besteht, dass die Startoption quiet "etwas" vor Ihnen verbirgt, wenn Sie sehen, was Sie beschreiben. Zum Beispiel könnte ich einen meiner Vorfälle aufspüren, bei dem das System meine Festplatte wiederherstellt (nicht die übliche Routineprüfung). Ich habe seitdem die Option quiet aus meinen Grub-Einträgen entfernt.

1
Hanno Fietz

Ich hatte dieses Problem in der Vergangenheit und stellte fest, dass es auf einigen Kerneln und nicht auf anderen Kerneln auftritt, obwohl ich dieses Problem seit dem Upgrade auf Meerkat nicht mehr hatte. Aber oft musste ich einen früheren Kernel auswählen, um ihn ordnungsgemäß in Ubuntu zu laden.

1
NW15062

Ich mag die Antwort von Maco, aber ich würde auch prüfen, ob Ihre Festplatte fehlerfrei ist. Überprüfen Sie unter System> Administration> Festplatten-Dienstprogramm den Status SMART. Er sollte "Festplatte ist fehlerfrei" lauten, da sonst möglicherweise ein Laufwerksfehler auftritt.

1
dgmdan

Ich hatte dieses Problem mit einer Neuinstallation von 11.10 Server.

Ich konnte mit Alt-F1 zu einem VT wechseln, so dass die Maschine am Leben war, aber zu VT7 gewechselt war, obwohl kein X aktiviert war.

Ich habe das Problem behoben, indem ich die Option GRUB_CMDLINE_LINUX_DEFAULT von quiet slash in nomodeset geändert habe, was bedeutete, dass ich die richtigen Startinformationen gefolgt von VT1 erhalten habe.

1
Douglas Leeder

nach dem Neustart neu installierte Ubuntu 10.04 in IBM x3250 m3 Server. Ich habe versucht, die Umschalttaste und einige andere Dinge zu halten, aber nichts hilft wirklich ... Ich habe versucht, es mehr als 5 Mal neu zu installieren. Das Hauptproblem ist seine Inkonsistenz. Manchmal wird gebootet, aber meistens nur ein leerer Bildschirm mit einem blinkenden Cursor oben links auf dem Bildschirm.

0
rael

Ich hatte in der Vergangenheit ein ähnliches Problem mit der empfohlenen Version eines proprietären nVidia-Treibers mit einer bestimmten Grafikkarte. Die Lösung bestand darin, in den Wiederherstellungsmodus zu booten, die Option xfix auszuführen und dann den Desktop zu booten. Sobald ich auf dem Desktop bin, gehe ich zum Bildschirm mit den Hardwaretreibern und wähle eine ältere Version des Treibers aus.

0
tj111

Ich hatte dieses Problem bei einigen billigen HP Notebooks mit 10.04. Ich habe festgestellt, dass häufig USB-Mäuse die Ursache sind. Ziehen Sie den Stecker heraus. Außerdem kann ein BIOS-Update helfen.

0
Extender

In meinem Fall für die obige Beschreibung (manchmal wird ein schwarzer Bildschirm mit einem blinkenden Cursor angezeigt) war es das Problem, dass lightgdm eine Racebedingung hatte und nicht richtig starten konnte. siehe meine vollständige Antwort auf diese andere verwandte Frage .

Einzelheiten zur Lösung finden Sie hier: http://www.webupd8.org/2013/01/ubuntu-lightdm-black-screen-when-using.html (siehe auch this Fehlerbericht ).

Das Wesentliche dabei: Verwenden Sie gdm und nicht lightgdm (d. H. Sudo apt-get install gdm und wählen Sie gdm als Standard-Login-Manager, wenn Sie dazu aufgefordert werden).

Hoffe das hilft jemandem.

0
codeling

Ich habe dieses Problem heute erlebt. Nach mehreren vergeblichen Versuchen, das System zu booten, habe ich mich entschlossen, von einem anderen Kernel aus zu booten. Ich habe sowohl einen 2.6.32-21-generischen Kernel als auch einen 2.6.32-25-generischen Kernel, der von Ubuntu bereitgestellt wird. Normalerweise boote ich vom 2.6.32.25-Kernel, aber nach dem ganzen Fiasko mit dem leeren Bildschirm habe ich vom 2.6.32.21-Kernel gebootet, und das erlaubte mir, wie gewohnt zu booten ...

0
Dananjaya

Folgendes habe ich falsch gemacht: Ich habe 14.04 auf einem alten Acer Netbook installiert. Beim Booten des Acer stehen zwei Optionen zur Verfügung: F2, um das BIOS aufzurufen und die Boot-Sequenz für den Computer zurückzusetzen, oder F12, um die Sequenz für eine Sitzung zurückzusetzen . Da ich von einem Memory Stick installiert habe, habe ich dummerweise die Startsequenz des Computers anstelle der Sitzungssequenz auf den Memory Stick zurückgesetzt. Daher wurden anstelle der Festplatte die wichtigsten Startdateien auf dem Memory Stick installiert.

0
Michael Blum