it-swarm-eu.dev

Ubuntu 14.10 se nenainstaluje ve virtuální schránce

V současné době používám Windows 8.1 x64 (problém sám o sobě, že se nemůžu smutně změnit ;-P) s nejnovější verzí VirtualBox (4.3.18 r96516). Podařilo se mi uvést verzi serveru do provozu bez problémů, ale nemohu spustit verzi pro počítač.

Mohu zavést systém do nabídky a zahájit proces (vyberte možnost instalace a/nebo vyzkoušet) a dostane se přes úvodní obrazovku načítání Ubuntu 14.10 (s progess "bar/tečky"), ale pak se dostaneme na ošklivou obrazovku zkreslených barev a to je vše.

Moje hypotéza je, že ovladač zobrazení/server nepracuje s VirtualBoxem a co v podstatě vidím, je displej v mizerném režimu (16colors @ 62x24), protože jsem schopen vidět dokonale jemnou obrazovku s kurzorem a všechno a pak najednou jsem na té ošklivé obrazovce. Myš se objeví (ošklivé pohledu a vyplnění celé obrazovky), ale nic jiného.

Zde je snímek obrazovky:

enter image description here

Zde jsou moje nastavení v albu (v případě potřeby mohu přidat více, ale vložím to, co jsem považoval za nejdůležitější):

enter image description here

enter image description here

enter image description here

enter image description here

127
MVit

Udeřil Right Ctrl+F1 (uvidíte Shell) a pak Right Ctrl+F7. V závislosti na konfiguraci Virtualbox použití Left Ctrl+Alt společně místo Right Ctrl.

Je dobré pokračovat v instalaci.


To funguje tak, že nutíte jádro grafického bufferu/X/XRandR znovu detekovat monitor a zobrazit ve správném rozlišení.

166
Gipnokote

Musíte přepínat mezi tty, takže GUI Guest se může sám aktualizovat a správně detekovat prostředí. Toto je v současné době drobná chyba.

Navrhoval bych dělat CTRL+ALT+F1 a pak CTRL+ALT+F7 ale pokud jste jako já, obdržel by to hostitel a ne host.

Správná kombinace kláves pro přepnutí na tty1 při zaostření na okno hosta je:

RIGHT CTRL+F1

následován

RIGHT CTRL+F7

Všiml jsem si, že používám RIGHT CTRL což je stejné, jaké používá VirtualBox k úniku ze zaměření VM.

Testováno s:

  • VirtualBox 4.3.18
  • Hostujte Ubuntu 14.10 64-bit
  • Host Ubuntu 14.10 64-bit

Dalším způsobem, jak to funguje, je zmínka o Whaaaatovi. V části VM Nastavení) v části Systém aktivujte zaškrtávací políčko Povolit EFI.

enter image description here

Rovněž se ujistěte, že je vaše čipová sada nastavena také na PIIX, protože ICH9 nebude fungovat. Ponechá vás na černé obrazovce.

enter image description here

Je-li EFI povoleno, může spouštěcí proces trvat trochu déle a obrazovka může zůstat černá, dokud se při spuštění neobjeví logo Ubuntu. Pokud vidíte Zavedení do zabezpečeného režim hned po spuštění VM), nebudete mít žádné problémy, pokud ne, pak chvíli počkejte.

enter image description here

enter image description here

Všimněte si, že jsem to testoval s 32 MB videa, 64 MB videa a 128 MB videa. Video nemá nic společného s problémem v 32bitovém ani 64bitovém formátu.

33
Luis Alvarado

Povolit režim EFI.

enter image description here

Při spouštění se může objevit několik chyb. Jsou však neškodné a nedělají nic pro váš systém. Bude to stále fungovat.

Při použití režimu EFI se ujistěte, že je sada čipů nastavena na režim PIIX3, jako na mém obrázku. Mít to na ICH9 je není zábava. PIIX3 je však výchozí, takže jej nemusíte nastavovat.

Ubuntu a EFI se nyní zjevně podobají sobě, takže spolu pracují lépe než sám.

16
Kaz Wolfe

Změnil jsem čipovou sadu na ICH9, deaktivoval jsem vnořené stránkování. To mi to vyřešilo.

3
88weighed

Myslím, že je problém s 64 bitovými verzemi. Na stejném virtuálním počítači 64 bit nefunguje, ale 32 ano. Se 128M videa funguje dobře 64bitové.

2
Think