it-swarm-eu.dev

Jak nainstalovat glib?

Chci postavit Empathy v Ubuntu 11.04. Když sleduji proces sestavení,

 ./autogen.sh

Shell mi to řekl

libtoolize: copying file `m4/lt~obsolete.m4'
checking for autoconf >= 2.53...
testing autoconf2.50... not found.
testing autoconf... found 2.67
checking for automake >= 1.9...
testing automake-1.11... found 1.11.1
checking for libtool >= 1.5...
testing libtoolize... found 2.2.6b
checking for glib-gettext >= 2.2.0...
testing glib-gettextize... not found.
***Error***: You must have glib-gettext >= 2.2.0 installed
to build Empathy.  Download the appropriate package for
from your distribution or get the source tarball at
ftp://ftp.gtk.org/pub/gtk/v2.2/glib-2.2.0.tar.gz

Ale když nemůžu najít způsob, jak nainstalovat glib. Co mám udělat, abych to nainstaloval v Ubuntu 11?

42
user8260

Pro glib-gettext potřebujete libglib2.0-dev. Můžete jej nainstalovat pomocí

Sudo apt-get install libglib2.0-dev
90
binW

musíte také nainstalovat libgtk2.0-dev, abyste mohli nainstalovat glib úplně (glib je součástí: libgtk2.0-dev)

Sudo apt-get install libgtk2.0-dev

viz tento odkaz pro další vysvětlení: instalace gtk a glib

6
Ali.A

Doporučuji vám vyhledat dostupné PDA, pokud si chcete jen vyzkoušet novější empatii, než máte. Myslím, že toto ppa je nejlepší sázka Nebo to prostě udělej

Sudo add-apt-repository ppa:telepathy/ppa

Nebo pokud to potřebujete postavit.

Sudo apt-get build-dep empathy

který nainstaluje všechny závislosti potřebné k vytvoření empatie ze zdroje.

3
sagarchalise