it-swarm-eu.dev

WordPress 3.0.1 Problém s automatickou aktualizací

Moje WordPress je nyní ve verzi 2.7. Chci upgradovat na verzi 3.0.1 pomocí funkce Automatické aktualizace. Používám typ připojení FTPS.

Aktualizace by měla být přímá, ale stále se setkávám s touto chybou:

Instalace se nezdařila Stahování aktualizace z http://wordpress.org/wordpress-3.0.1.Zip

Rozbalení aktualizace…

Ověření rozbalených souborů…

Instalace nejnovější verze…

Nelze kopírovat soubor .: /wp-admin/css/theme-editor.dev.css

Instalace selhala

Zkontroloval jsem oprávnění pro složku /wp-admin/css a je nastaven na 777.

Co je za problém? Hledal jsem na internetu, ale zdá se, že spousta lidímá stejný problém .

Nějaké nápady?

2
Graviton

Automatická aktualizace vždy nefunguje, téměř vždy funguje. Já bych jen upgrade ručně a nestarat se o to. Několikrát jsem měl automatické aktualizace selhání to uspěje příště nová verze vyjde (poté, co jsem ručně aktualizován během zlomení).

2
curtismchale

K dispozici je patch (http://core.trac.wordpress.org/ticket/10913) pro WordPress, který by měl jít do 3.2 a pomoci opravit tuto chybu upgrade pro většinu lidí běží do něj. Zdá se, že se to děje pouze u serverů s Pure-FTPd. Mezitím existuje plugin, který by měl pomoci opravit aktualizace pro většinu lidí: http://wordpress.org/extend/plugins/ftp-upgrade-fix/

2
user3757

Zkontrolujte, zda je vlastník souboru/s nastaven na 777, ale pokud služba ftp není ve skupině vlastníků nebo vlastníkovi, může se stát, že váš problém

Chcete-li zkontrolovat/opravit nás ls -l, musíte telnet do webového serveru zkontrolovat/opravit.

0
Pbearne

Zkoušel jsem všechno pro automatickou aktualizaci, která byla zmíněna na wordpress.org/support/topic/upgrade-gone-worng-pls-help, ale bez úspěchu.

Místo toho jsem provedl ruční upgrade víceméně podle instrukcí na codex.wordpress.org/Upgrading_WordPress. Namísto použití FTP jsem použil poskytovatele hostingu CPanel - pak jsem blogoval kroky, které jsem udělal, aby ostatní mohli těžit - viz http://misterjaytee.com/2010/09/11/errors -updating-wordpress .

Doufejme, že další automatický upgrade bude fungovat správně, ale pokud ne, mám nyní jistotu, že upgrade provedu ručně.

0
misterjaytee
0
Nabeel

Zkontrolujte oprávnění na odkazovaný soubor. V tomto případě: /wp-admin/css/theme-editor.dev.css.

0
artlung