it-swarm-eu.dev

Bude Drupal 6 6 zůstane v bezpečném stavu poté, co se stane nepodporovaným?

Vytvořil jsem vlastní databázové rozhraní pomocí Drupal 6 + Zobrazení + CCK , které funguje opravdu dobře pro svou společnost a nedávno jsem ji musel přenést na jiný server.

Myslel jsem "Ahoj, proč neinstalovat Drupal 7 a pak do něj vypsat databázi: pak můžu upgradovat Drupal) na nejnovější verzi během migrace!? “

To se ukázalo jako špatný nápad. Drupal 7 nemá nejmenší ponětí, co dělat s informacemi o DB, které jsem mu dal. A průvodce upgradem mi teď vypadá velmi časově náročný.

Takže moje otázka zní: bude Drupal 6 6 zůstane v bezpečném stavu poté, co se stane nepodporovaným? Nebo bude platforma zastaralá a zranitelná, což na mě bude nutit ještě masivnější upgrade?

8
Garrett

Myslím, že dokud některé z hlavních přispěných modulů, jako je Views, nebudou mít moduly Drupal7 stabilní a ne alfa, beta, myslím si, že drupal6 bude nějakou dobu používán.

Jsem si jistý, že drupal6 bude podporován pro nadcházející roky, protože existuje spousta webů drupal6.

Odpověď zní: Ne, nemusíte upgradovat.

8
Camsoft

Jakmile Drupal 8 vyjde, Drupal 6 bude označeno jako „konec životnosti“: Drupal bezpečnostní tým se zastaví) pracuje na tom a oficiální bezpečnostní vydání za to nepřijdou. Pokud se objeví nová zranitelnost, musíte ji napravit sami. Takže v tomto okamžiku je opravdu přínosem upgradovat.

Cesty pro upgrade pro Drupal jsou z předchozí verze na aktuální verzi: to znamená, že cesta k upgradu je poskytována od posledního vydání Drupal 6 na = Drupal 7, a cesta k upgradu bude poskytována od Drupal 7 na Drupal 8).

Nebude existovat cesta pro upgrade pro Drupal 6 na Drupal 8: Pokud nechcete znovu vytvořit svůj web od začátku, kdy Drupal 8, musíte nejprve upgradovat Drupal 6 web na Drupal 7, poté upgradovat na Drupal 8.

Skutečně tedy jde o ekonomii a dlouhodobé plánování. Drupal 6 bude podporováno do Drupal 8, ale když Drupal 8 vyjde za pár let), budete Máte příležitost přepsat web? Pokud ne, měli byste plánovat upgrade na Drupal 7 v budoucnu.

15
user7

Podporovány jsou vždy 2 verze Drupal. Když tedy bude vydáno Drupal 8, Drupal 6 nebude podporováno. Zbývá ještě nějaký čas, než se to stane, takže se nemusíte spěchat.

Pokud je dostatek lidí ochotných nadále opravovat chyby zabezpečení, můžete je bezpečně používat, i když již není oficiálně podporována. Každý, kdo chce pokračovat v podpoře Drupal 6 bezpečnostními záplatami na neurčito, je otázkou, zda je o to dost lidí dost. Nepočítal bych s tím, že Drupal 6 bude po oficiálním vydání Drupal 8 stále podporován.

4
Mad Scientist

Váš původní problém spočívá v tom, že nechcete trávit obrovské množství času upgradováním vašeho webu - to chápu dobře, ale určitě bych doporučil provést upgrade. Několik důvodů:

  • Dříve nebo později budete muset upgradovat , protože Drupal 6 se blíží konec životnosti .
  • Pokud pracujete s webovými stránkami Drupal), budete mít velkou výhodu, pokud se naučíte, jak provést hlavní upgrade. Mnoho lidí jako já začalo s Drupal 6) , jedná se tedy o první upgrade, který bychom měli být schopni aplikovat - je to cenné znalosti.
  • Můžete "změnit" proces aktualizace popsaný v příručce - nikdo zmínil se o tom, že byste měli udělat že například jednoho odpoledne ... Kdybych byl ty, tak bych strávil několik hodin přípravami, kontrolami modulů a témat, kontrolou jádra atd. a další den jsem pokračoval upgradem v testovací prostředí. Tímto způsobem můžete mít trochu větší pohodlí. Hlavní věc je pořizovat si poznámky o všem . Je lepší mít každé kliknutí zdokumentováno (což by bylo šílené), než mít zapsáno nic. Zkuste si to užít, upgradovaný web bude lepší než kdy jindy!

A pamatujte, že máme obrovskou komunitu se spoustou energie a podpory, takže mluvte o tom, co děláte, napište blogový příspěvek nebo něco - někdo bude těžit z toho velmi, snad i vy.

2
Scorchio

Asi 5 let po položení této otázky je zde další odpověď na základě toho, co víme dnes ...

Bude Drupal 6 6 zůstane v bezpečném stavu, přijde den, kdy není podporován?

Drupal 6 byl vyhlášen jako konec životnosti k 24. únoru 2016, jak je podrobně uvedeno v Drupal 6 oznámení o ukončení života (*) . Pokud tedy neučiníte vhodné kroky, hrozí, že weby, které budou po tomto datu stále používat Drupal 6 po tomto datu), se stanou nebezpečnými.

Mezitím byl ale uvolněn modul myDropWizard ... pro D6 ... stále a !!!. Další podrobnosti naleznete v části „ Jak získat přesné informace o dostupných aktualizacích zabezpečení po skončení životnosti? “.

Nebo bude platforma zastaralá a zranitelná, což na mě nutí ještě masivnější upgrade?

V situacích, kdy „ upgradování webu D6 není možnost “, je možná alternativa Buy = Drupal 6 dlouhodobá podpora (LTS) od jednoho z „ oficiálních “ dodavatelů . Zdá se, že se jedná o projekt D6LTS . Další podrobnosti naleznete v odpovědi na otázku Jak postupovat s webem D6 po 24. únoru 2016, kdy je D6 na konci života? =.

Pro ty, kteří se zajímají " Kolik bylo nahlášeno Drupal 6 instalací, které nám zbývají? ", přejděte na Statistiky použití pro = Drupal jádro (o D5, D6, D7, D8) ... K 31. lednu 2016 se zdá, že „ pouze „zbývá asi 110 000 stránek (ve srovnání s přibližně 1046 tis. pro D7 a 64 tis. pro D8). To je asi o 40 tis. méně než před rokem (při této rychlosti to bude trvat další 3 až 4 roky ...).

(*) : tento odkaz obsahuje také spoustu zajímavých komentářů, jako je úplně první komentář pod ním , což je jako tak:

Podle definice je vydání na stránce projektu podporováno, pokud existují dvě podmínky:

  1. správce projektu věří, že je podporován.
  2. bezpečnostní tým přijímá zprávy o bezpečnostních otázkách a vydává o nich rady.

To je stav „podporovaného“ znamená a znamená od května 2009 (a zopakováno v květen 201 ).

Proto je položka 4 v tomto seznamu:

Všechno Drupal 6 vydání na stránkách projektu bude označeno jako nepodporované.

Od vydání Drupal 6 EOL) již nebude položka č. 2 pravdivá, takže má smysl je označovat jako nepodporované.

Tento příspěvek o EOL je výsledkem četných rozhovorů za poslední 3 roky o tom, kdy by EOL měla být. Lidé, kteří chtějí, aby byla podpora Drupal 6 a/nebo přispívající moduly) delší.

2
Pierre.Vriens

Když vyjde nová verze Drupal verze, neexistuje žádný pokus, aby nové sestavení byly „zpětně kompatibilní“ se starými. Některé základní věci se změnily s Drupal 7, včetně skutečnosti, že to, co bylo modulem „CCK“, je nyní součástí základní funkce Drupalu. Takže instalace Drupal 7 nebude vědět, co dělat s Drupal 6 databáze, pokud nedodržíte doporučený postup aktualizace . (A i tehdy, pokud jste přizpůsobili nějaké moduly nebo vytvořili své vlastní moduly nebo šablony, budete muset udělat nějakou práci pro úplné převedení aplikace.)

To znamená, že ne, nemusíte upgradovat , alespoň ne nyní. Jste v pořádku držet se Drupal 6 až do Drupal 8 vyjde, jak na to ostatní poukázali.) Mohli byste spustit paralelu Drupal 7 server na instalaci MAMP nebo WAMP na vlastní pevný disk a použijte jej k praktickému přenesení aplikace na Drupal 7. Jednou Drupal 8) vyjde, měli byste být připraveni upgradovat vaši aplikaci na Drupal 7 (a všechny ostatní moduly, které jste nainstalovali, by do té doby měly dobýt D7).

1
JR Dixey